<!DOCTYPE html>
<html>
<head>
	<meta charset="UTF-8">		
	<meta http-equiv="X-UA-Compatible" content="IE=EDGE">		
	<meta name="viewport" content="width=device-width, initial-scale=1.0"> 
	<link rel="stylesheet" href="//i.ubm-us.net/oas/nativead/css/nojitter_nativead.css">
<script language="JavaScript" src="//i.ubm-us.net/oas/nativead/js/nativead.js"></script>
<script language="JavaScript" src="//i.ubm-us.net/oas/nativead/js/nojitter_nativead.js"></script>
<link rel="icon" href="http://twimgs.com/nojitter/favicon.ico?v3" />
<link rel="shortcut icon" href="http://twimgs.com/nojitter/favicon.ico?v3" />
	<link rel="image_src" href="//twimgs.com/nojitter/v2/images/site/nojitter.jpg" />
	
	<title>A Primer on API Integration - Post - No Jitter</title><meta name="description" content="What you need to know as you consider communications APIs, and beyond" />
<meta name="headline" content="A Primer on API Integration" />
<meta name="news_keywords" content="communications APIs, APIs, primer, API integration, Pedro Pinto, Huddle" />
<meta name="created" content="June 15, 2017" />
<meta name="y_key" content="" />
<meta name="robots" content="" />
<meta name="google-site-verification" content="" />
<meta name="original-source" content="http://www.nojitter.com/post/240172721/a-primer-on-api-integration" />
<meta property="og:title" content="A Primer on API Integration" />
<meta property="og:image" content="http://img.deusm.com/facebook/nojitter_logo.jpg" />
<meta property="og:type" content="article" />
<meta property="og:url" content="http://www.nojitter.com/post/240172721/a-primer-on-api-integration" />
<script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jquery/1.10.2/jquery.min.js"></script>

<script type="text/javascript">
    //<![CDATA[
$.ajax({
	   type: "GET",
	   url: "/checkauth",
	   data: {"referer": encodeURIComponent(document.referrer), "redirectTo": encodeURIComponent(window.location.href)},
	   success: function(data){
		   if (data != null)
			{
				window.location = data.redirectTo;
			}
	   },
	   dataType: "json",
	   async: false,
	   cache: false
	 });    //]]>
</script>
<script type="text/javascript" src="https://i.cmpnet.com/informationweek/whitepaper/v3/common/js/jquery.url.js"></script>
<script type="text/javascript" src="https://i.cmpnet.com/informationweek/whitepaper/v3/common/js/md5_hash.js"></script>
<script type="text/javascript" src="https://i.cmpnet.com/informationweek/whitepaper/v3/common/js/twlightbox.js"></script>
<script type="text/javascript" src="https://twimgs.com/nojitter/js/nojitternextgen.js?v4"></script><link href="https://i.cmpnet.com/informationweek/whitepaper/v3/common/css/twlightbox.css" media="screen" rel="stylesheet" type="text/css" />

<script type="text/javascript">
//<![CDATA[
$(document).ready(function() {
    			$.ajax({
			  url: "/index/welcome",
			  type: 'POST',
			  data: {"redirectTo": encodeURIComponent(window.location.href) },
			  success: function(data) {			  
			    $('.welcome').html(data);
			    $('.welcome').nextGenInit({				
					width: 780,
					siteUrlPrefix:'',
					siteRedirectPrefix: ''
				});
			  }
			});
});
//]]>

</script><!-- Start: GPT Sync -->

<script type="text/javascript">
var _AdsNativeOpts =
{ keywords: ['post']};
</script>

<script type='text/javascript'>
 var gptadslots=[];
 (function(){
  var useSSL = 'https:' == document.location.protocol;
  var src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
  document.write('<scr' + 'ipt src="' + src + '"></scr' + 'ipt>');
 })();
</script>

<script type="text/javascript">


 googletag.pubads().setTargeting('kw',['communications-APIs','APIs','primer','API-integration','Pedro-Pinto','Huddle']);
 googletag.pubads().setTargeting('aid',['240172721']);                       if (document.documentElement.clientWidth > 767){
            gptadslots[1]=googletag.defineSlot('/2441/NoJitter/post/240172721/a-primer-on-api-integration',[[2,2]],'div-gpt-ad-942957474691236830-1')
.addService(googletag.pubads())
.setTargeting('pos',['welcome']);
            }else{
            gptadslots[35]=googletag.defineSlot('/2441/NoJitter/post/240172721/a-primer-on-api-integration',[[7,7]],'div-gpt-ad-942957474691236830-35')
.addService(googletag.pubads())
.setTargeting('pos',['mi']);
            }
            			if (document.documentElement.clientWidth > 1027){
			gptadslots[2]=googletag.defineSlot('/2441/NoJitter/post/240172721/a-primer-on-api-integration',[[1,2]],'div-gpt-ad-942957474691236830-2')
.addService(googletag.pubads())
.setTargeting('pos',['wallpaper']);
			}
						if (document.documentElement.clientWidth > 767){
			gptadslots[3]=googletag.defineSlot('/2441/NoJitter/post/240172721/a-primer-on-api-integration',[[728,90],[970,250]],'div-gpt-ad-942957474691236830-3')
.addService(googletag.pubads())
.setTargeting('pos',['top']);
			}
			gptadslots[4]=googletag.defineSlot('/2441/NoJitter/post/240172721/a-primer-on-api-integration',[[300,250],[300,600],[336,280],[336,850]],'div-gpt-ad-942957474691236830-4')
.addService(googletag.pubads())
.setTargeting('pos',['rec1']);
			if (document.documentElement.clientWidth > 767){
			gptadslots[8]=googletag.defineSlot('/2441/NoJitter/post/240172721/a-primer-on-api-integration',[[728,90]],'div-gpt-ad-942957474691236830-8')
.addService(googletag.pubads())
.setTargeting('pos',['bottom']);
			}
			gptadslots[21]=googletag.defineSlot('/2441/NoJitter/post/240172721/a-primer-on-api-integration',[[336,90]],'div-gpt-ad-942957474691236830-21')
.addService(googletag.pubads())
.setTargeting('pos',['Promo1']);
		if (document.documentElement.clientWidth > 620){
		 gptadslots[30]=googletag.defineSlot('/2441/NoJitter/post/240172721/a-primer-on-api-integration',[[620,67]],'div-gpt-ad-942957474691236830-30')
.addService(googletag.pubads())
.setTargeting('pos',['homepromo1']);
		}
				if (document.documentElement.clientWidth > 620){
		 gptadslots[31]=googletag.defineSlot('/2441/NoJitter/post/240172721/a-primer-on-api-integration',[[620,67]],'div-gpt-ad-942957474691236830-31')
.addService(googletag.pubads())
.setTargeting('pos',['homepromo2']);
		}
		                if (document.documentElement.clientWidth <= 620){
                 gptadslots[32]=googletag.defineSlot('/2441/NoJitter/post/240172721/a-primer-on-api-integration',[[300,50]],'div-gpt-ad-942957474691236830-32')
.addService(googletag.pubads())
.setTargeting('pos',['mobilepromo1']);
                }
                                if (document.documentElement.clientWidth <= 620){
                 gptadslots[33]=googletag.defineSlot('/2441/NoJitter/post/240172721/a-primer-on-api-integration',[[300,50]],'div-gpt-ad-942957474691236830-33')
.addService(googletag.pubads())
.setTargeting('pos',['mobilepromo2']);
                }
                gptadslots[34]=googletag.defineSlot('/2441/NoJitter/post/240172721/a-primer-on-api-integration',[[300,60]],'div-gpt-ad-942957474691236830-34')
.addService(googletag.pubads())
.setTargeting('pos',['eventpromo']);
gptadslots[36]=googletag.defineSlot('/2441/NoJitter/post/240172721/a-primer-on-api-integration',[[300,250]],'div-gpt-ad-942957474691236830-36')
.addService(googletag.pubads())
.setTargeting('pos',['smartbox']);
gptadslots[38]=googletag.defineSlot('/2441/NoJitter/post/240172721/a-primer-on-api-integration',[[8,2]],'div-gpt-ad-942957474691236830-38')
.addService(googletag.pubads())
.setTargeting('pos',['native']);
googletag.pubads().enableSingleRequest();
googletag.pubads().enableSyncRendering();
googletag.enableServices();
</script>
<!-- Begin ADSNATIVE Code -->
<script type="text/javascript" src="//static.adsnative.com/static/js/render.v1.js"></script>
<!-- End ADSNATIVE Code -->
   
    	<style>
		.author img {
		display:block !important;
		}
		</style>
        <script type="text/javascript" src="//code.jquery.com/jquery-migrate-1.2.1.js"></script>
	<link rel="stylesheet" href="//code.jquery.com/mobile/1.4.1/jquery.mobile-1.4.1.min.css" />	
	
	
	<link rel="stylesheet" href="//twimgs.com/nojitter/v2/css/grid.css" type="text/css" media="screen, projection" />
	<link rel="stylesheet" href="//twimgs.com/nojitter/css/nojitterstyle.css" type="text/css" />	
	<link rel="stylesheet" href="//twimgs.com/nojitter/v2/css/typography.css" type="text/css" />
	<link rel="stylesheet" href="//twimgs.com/nojitter/v2/css/print.css"  media="print" type="text/css" />
	<link rel="stylesheet" href="https://twimgs.com/nojitter/css/superfooter.css?v1" type="text/css" />
    	
	<link rel="stylesheet" href="https://twimgs.com/nojitter/css/mobile.css?v1" type="text/css" />
	<![if !IE]>
		<script src="https://twimgs.com/nojitter/js/responsive.js" type="text/javascript"></script>
	<![endif]>
         <script type='text/javascript'>
 		 $(document).bind("mobileinit", function() {
			  $.mobile.ignoreContentEnabled = true;
			});
 		 </script>
         <script src="//code.jquery.com/mobile/1.4.1/jquery.mobile-1.4.1.min.js"></script> 
                <script src="//twimgs.com/nojitter/v2/js/jquery.noJitterTabs.min.js" type="text/javascript"></script>
	<link media="screen" rel="stylesheet" href="//twimgs.com/brainyard/css/colorbox.css" type="text/css" />
	<script type="text/javascript" src="//twimgs.com/brainyard/js/colorbox/jquery.colorbox-min.js"></script>
    <link href="/rss/" rel="alternate" type="application/rss+xml" title="No Jitter RSS" />
		<link rel="canonical" href="http://www.nojitter.com/post/240172721/a-primer-on-api-integration" />
		<![if !IE]>
	<script type="text/javascript">
		var randCache = 379949;
		console.log(randCache);
				var zsnode = 03;
		console.log(zsnode);
			</script>
	<![endif]>
	<!- IE 9 issue fix  ->
	<script type="text/javascript">
           $(document).ready(function () {
           if ($.browser.msie || $.browser.webkit) {

               $("a").attr("rel", "external");
		$("#headerSearch form").attr("data-ajax", "false");
               var a = $("form");
               if (a != null) {
                   $("form").first().attr("rel", "external");
               }
           }
       });
   </script>

</head>
<body>
			<div id='div-gpt-ad-942957474691236830-1'>
			<script type='text/javascript'>
				googletag.display('div-gpt-ad-942957474691236830-1');
			</script>
		</div>
				<div id='div-gpt-ad-942957474691236830-35'>
			<script type='text/javascript'>
				googletag.display('div-gpt-ad-942957474691236830-35');
			</script>
		</div>
	<div data-role="page">
<div data-role="panel" id="mypanel" data-display="push">
<!-- panel content goes here -->
</div><!-- /panel -->
<!--leaderboard-->
<div id="header_events_social">
	<div class="cont">
		<!--list of all event locations-->
		<ul class="menu_events">
			<li><a href="http://www.enterpriseconnect.com/orlando/?_itc=WE_EC_LE_TOPTEXT_ECOR14" target="_blank">Enterprise Connect: Orlando</a></li>
			<li><a href="//www.nojitter.com/enterprise-connect?_mc=BA_NJ_COVERAGE">No Jitter Coverage</a></li>
			<li><a href="http://www.enterpriseconnect.com/summit" target="_blank">Summit Series</a></li>
			<li><a href="http://www.enterpriseconnect.com/virtualevents/" target="_blank">Virtual Events</a></li>
			<li><a href="http://www.enterpriseconnect.com/webinar/" target="_blank">Webinars</a></li>
		</ul>	
		<span id="headerSearch">
			<form action="/sitesearch" method="get" > 
				<input type="hidden" name="sort" value="publishDate desc"/>
				<div class="right button">
					<input name="Search" type="image" src="//twimgs.com/nojitter/v2/images/btn/btn_search.png" value="Submit" />
				</div>
				<div class="right entry"><input type="text" id="queryText" name="queryText" value="Search No Jitter" size="34" onfocus="if(this.value=='Search No Jitter')this.value='';" onblur="if(this.value=='')this.value='Search No Jitter';"  /></div>
			</form>                 
		</span>
	</div>
</div>
<div id="topAdContainer"> 
			<div id='div-gpt-ad-942957474691236830-2'>
			<script type='text/javascript'>
				googletag.display('div-gpt-ad-942957474691236830-2');
			</script>
		</div>
	</div>
<div class="leaderboard_ad">
			<div id='div-gpt-ad-942957474691236830-3'>
			<script type='text/javascript'>
				googletag.display('div-gpt-ad-942957474691236830-3');
			</script>
		</div>
	</div><!--header-->
<div class="container" data-role="header">
   <div class="span-24 last">
        <div id="header"> 
	<style type="text/css">
@media (max-width: 640px) {
	#header .mobileheaderSearch {
		/*float: right;*/
		clear: both;
		/*margin: 7px 15px 0 5px;*/
		width: 95%;
	}
	.mobileheaderSearch .entry{
		width: 75%; 
	}
	.mobileheaderSearch .entry .ui-input-text{
		color: #16153b !important;
	}
	.mobileheaderSearch .button{
		width: 25%; 
	}
	.mobileheaderSearch .button input{
		margin-left: 2px;
		/*margin-right: 2px;
		margin-top: 5px;
		width: 20px;*/
	}
	#mobile-nav-button{
		top: 73px !important;
	}

	#header {
		background: transparent url("//twimgs.com/nojitter/v2/images/site/mobile/NJT_MobileHeader320_v3.png") no-repeat scroll 0 70px !important;
		height: 178px !important;
	}

	#headerOverlay {
		top: 70px !important;
	}

	.social-icons {
		top: 147px !important;
	}
}
</style>
<div class="loginLinks welcome" id="welcome">
</div>
<div class="mobileheaderSearch mobile-unit">
	<form action="/sitesearch" method="get" >
		<input type="hidden" name="sort" value="publishDate desc"/>
		<div class="left entry">
			<input type="text" id="queryText" name="queryText" value="Search" onfocus="if(this.value=='Search')this.value='';" onblur="if(this.value=='')this.value='Search';"  />
		</div>
		<div class="left button">
			<input name="Search" type="image" src="//twimgs.com/nojitter/v2/images/btn/btn_search.png" value="Submit" />
		</div>		
	</form>
	<div class="clear"></div>
</div>
<div class="clear"></div>
<br/>
<span id="headerOverlay">
	<a href="/"><img src="//twimgs.com/nojitter/v2/images/site/pixel.gif" alt="Home" width="440" height="121" /></a>
</span>


	
		<div class="social-icons">
			<a href="http://twitter.com/#!/nojitter" target="_blank" class="twitter"><span>Twitter</span></a>
			<a href="http://www.facebook.com/#!/pages/No-Jitter/168898416501054" target="_blank" class="facebook"><span>Facebook</span></a>
			<a href="http://www.linkedin.com/groups/Enterprise-Communications-News-on-NoJittercom-107451?gid=107451&trk=hb_side_g" target="_blank" class="linkedin"><span>Linked In</span></a>
			<a href="https://plus.google.com/+Nojitter" target="_blank" class="googleplus"><span>Google Plus</span></a>
			<a href="/about" target="_blank" alt="Contact Us" class="about" /><span>Contact Us</span></a>
			<a href="/rss" target="_blank" alt="RSS" class="rss" /><span>RSS</span></a>
		</div>

<!--SteelHouse Tracking Pixel-->
<!-- INSTALL ON ALL PAGES OF SITE-->
<script type="text/javascript">
(function(){"use strict";var e=null,b="4.0.0",
n="12094",
additional="",
t,r,i;try{t=top.document.referer!==""?encodeURIComponent(top.document.referrer.substring(0,2048)):""}catch(o){t=document.referrer!==null?document.referrer.toString().substring(0,2048):""}try{r=window&&window.top&&document.location&&window.top.location===document.location?document.location:window&&window.top&&window.top.location&&""!==window.top.location?window.top.location:document.location}catch(u){r=document.location}try{i=parent.location.href!==""?encodeURIComponent(parent.location.href.toString().substring(0,2048)):""}catch(a){try{i=r!==null?encodeURIComponent(r.toString().substring(0,2048)):""}catch(f){i=""}}var l,c=document.createElement("script"),h=null,p=document.getElementsByTagName("script"),d=Number(p.length)-1,v=document.getElementsByTagName("script")[d];if(typeof l==="undefined"){l=Math.floor(Math.random()*1e17)}h="dx.steelhousemedia.com/spx?"+"dxver="+b+"&shaid="+n+"&tdr="+t+"&plh="+i+"&cb="+l+additional;c.type="text/javascript";c.src=("https:"===document.location.protocol?"https://":"http://")+h;v.parentNode.insertBefore(c,v)})()
</script>


    <!--
	<div id="headerSocial">
		<img src="//twimgs.com/nojitter/v2/images/site/header_social.jpg"  alt="Social" border="0" usemap="#Social"  />
		<map name="Social" id="Social">
			<area shape="rect" coords="2,20,17,36" href="http://www.facebook.com/#!/pages/No-Jitter/168898416501054" target="_blank" alt="No Jitter on Facebook" />
			<area shape="rect" coords="85,20,100,37" href="/rss" target="_blank" alt="RSS" />
			<area shape="rect" coords="24,21,39,35" href="http://twitter.com/#!/nojitter" target="_blank" alt="Follow No Jitter on Twitter" />
			<area shape="rect" coords="44,20,59,35" href="http://www.linkedin.com/groups/Enterprise-Communications-News-on-NoJittercom-107451?gid=107451&trk=hb_side_g" target="_blank" alt="No Jitter on LinkedIn" />
			<area shape="rect" coords="66,20,81,36" href="/about/" target="_blank" alt="Contact Us" />
		</map>
	</div>
    -->  
</div>
<style>
span.left.navBtn.newsletterForm {
  
    margin: 0 !important;
    padding: 0px 0px 0 0px;
    float:right;
}
.newsletterForm img{
padding:0 !important;
}

</style>
<div id="topnav"> 
	<span class="left home"><a href="/"><img src="//twimgs.com/nojitter/v2/images/site/topnav_home3.png"  alt="Home" /></a></span>
	<span class="left link"> <a href="/posts/">POSTS</a></span>
	<span class="left"><img src="//twimgs.com/nojitter/v2/images/site/topnav_divider2.png"  alt="img" /></span>
	<span class="left link"><a href="/webinars/">WEBINARS</a></span>
	<span class="left"><img src="//twimgs.com/nojitter/v2/images/site/topnav_divider2.png"  alt="img" /></span>
	<span class="left link"><a href="/whitepapers/">WHITEPAPERS</a></span>
	<span class="left"><img src="//twimgs.com/nojitter/v2/images/site/topnav_divider2.png"  alt="img" /></span>
	<span class="left link"><a href="/research/">RESEARCH</a></span>	
	<span class="left"><img src="//twimgs.com/nojitter/v2/images/site/topnav_divider2.png"  alt="img" /></span>
	<span class="left link"><a href="/slideshows/">SLIDESHOWS</a></span>
	<span class="left"><img src="//twimgs.com/nojitter/v2/images/site/topnav_divider2.png"  alt="img" /></span>
	<span class="left link videolink"><a href="/videos/">VIDEOS</a></span>
	<span class="left"><img src="//twimgs.com/nojitter/v2/images/site/topnav_divider2.png"  alt="img" /></span>
 <span class="left link"><a href="/podcasts/">PODCASTS</a></span>
        <span class="left"><img src="//twimgs.com/nojitter/v2/images/site/topnav_divider2.png"  alt="img" /></span>
	<span class="left link"><a href="/about/">ABOUT</a></span>	

    <span class="left navBtn newsletterForm"><a href="http://reg.nojitter.com/Mailing_list"><img src="http://img.deusm.com/images/subscribenojitter.png"  alt="Subscribe to our newsletter" border="0" /></a></span>	
</div>
<div id="topsubnav">
 <span class="leftsub one "><a href="/cloud-communications">Cloud Communications</a></span>
 <span class="leftsub two  "><a href="/communications-apis">Communications APIs/Integration</a></span>
 <span class="leftsub three "><a href="/contact-center">Contact Center/ Customer Experience</a></span>
 <span class="leftsub four "><a href="/it-strategies">IT Strategies</a></span>
 <span class="leftsub five "><a href="/team-messaging">Messaging/Team Collaboration</a></span>
 <span class="leftsub six "><a href="/mobility">Mobility</a></span>
 <span class="leftsub seven "><a href="/sip-trunking">SIP/SIP Trunking</a></span>
 <span class="leftsub eight "><a href="/systems-management-network-design">Systems Management/ Network Design</a></span>
 <span class="leftsub nine "><a href="/unified-communications-collaboration">Unified Communications & Collaboration</a></span>
 <span class="leftsub ten "><a href="/video-section">Video</a></span>

</div>
<a id="mobile-nav-button" class="mobile-unit" href="#mypanel"><span>&nbsp;</span></a>
   </div>
	<!--main content-->
	<div class="span-15" style="background-color:#FFF !important;">
	<style>
.storynew.insetnew {
display: none;
}



@media screen and (max-width: 640px){
.social-icons{
}

.storynew.insetnew{
display:block;
}
.storynew.insetnew .title {
    color: #888;
    font-size: 13px;
    font-weight: normal;
}
.storynew .title {
    font-size: 26px;
    font-weight: bold;
    line-height: 33px;
}
}

</style>
 <div class="storynew insetnew" >
<div class="title">SHARE</div>
     <hr /><br/>
          <div class="share addthis_toolbox addthis_default_style">
                        <a class="addthis_button_facebook"></a>
                        <a class="addthis_button_linkedin"></a>
                        <a class="addthis_button_stumbleupon"></a>
                        <a class="addthis_button_favorites"></a>
                        <a class="addthis_button_google_plusone" g:plusone:count="false" g:plusone:annotation="none"></a>
                        <a class="addthis_button_twitter"></a>
                        <a class="addthis_button_reddit"></a>

                        <a class="addthis_button_email"></a>
                        <a class="addthis_button_print"></a>
                </div>               <hr />
     </div>

<div class="story inset">
<div class="title">ABOUT THE AUTHOR</div>
	<hr />
     <br />
          <div class="author">
     	<img src="http://twimgs.com/nojitter/ehk/BloggerHeadshots/PedroPinto_Huddle.JPG" alt="Pedro Pinto" width="50" height="62" />
     </div>
	      
     				Pedro is Head of Global Sales Engineering at Huddle, the enterprise collaboration company that helps organizations across the globe to...			<br/>
			<a href="/author/8574">Read Full Bio  &gt;&gt;</a><br/> 
		
<div class="title">SHARE</div>
     <hr /><br/>
          <div class="share addthis_toolbox addthis_default_style">
			<a class="addthis_button_facebook"></a>
 cc			<a class="addthis_button_linkedin"></a>
			<a class="addthis_button_stumbleupon"></a>
			<a class="addthis_button_favorites"></a>
			<a class="addthis_button_google_plusone" g:plusone:count="false" g:plusone:annotation="none"></a>			
			<a class="addthis_button_twitter"></a>
			<a class="addthis_button_reddit"></a>
		
			<a class="addthis_button_email"></a>
			<a class="addthis_button_print"></a>
		</div>			
     <hr />
     </div>
     <div class="story">
			 <div class="posting">
                          					<a href="/author/8574">Pedro Pinto</a> 
     				 | 
					<em>June 15, 2017</em> | 
					<img src="//twimgs.com/nojitter/v2/images/icon/icon_comment.png"> <a href="http://www.nojitter.com/post/240172721/a-primer-on-api-integration#disqus_thread"  ></a>
                                   		<p>
						<!-- BEGIN FB LIKE -->
<div style="float: left; margin-right: 5px;" class="share-facebook-likes">

                <script>

                                ( function(d, s, id) {
                                          var js, fjs = d.getElementsByTagName(s)[0];
                                          if (d.getElementById(id)) return;
                                          js = d.createElement(s); js.id = id;
                                          js.src = "//connect.facebook.net/en_US/all.js#xfbml=1";
                                          fjs.parentNode.insertBefore(js, fjs);
                                }
                                (document, 'script', 'facebook-jssdk'));</script>
        <fb:like send="false" action="like" layout="button_count" href="http%3A%2F%2Fwww.nojitter.com%2Fpost%2F240172721%2Fa-primer-on-api-integration" width="450" show_faces="true"></fb:like>

                </div> 
<!-- END FB LIKE -->



&nbsp;	
			 			<div style="float: left; margin-right: 0px;" class="share-tweet"><!-- BEGIN TWEET BUTTON --><a href="https://twitter.com/share" class="twitter-share-button" data-counturl="http://www.nojitter.com/post/240172721/a-primer-on-api-integration" data-url="http://ubm.io/2suxPzU" data-text="A Primer on API Integration" data-via="nojitter" data-related="nojitter" >Tweet</a><script type="text/javascript" charset="utf-8">window.twttr = (function (d,s,id) {var t, js, fjs = d.getElementsByTagName(s)[0];if (d.getElementById(id)) return; js=d.createElement(s); js.id=id;js.src="//platform.twitter.com/widgets.js"; fjs.parentNode.insertBefore(js, fjs);return window.twttr || (t = { _e: [], ready: function(f){ t._e.push(f) } });}(document, "script", "twitter-wjs"));
twttr.ready(function (twttr) {
	twttr.events.bind('tweet', function(event) {
		var tweet_id = event.data.tweet_id;
		var user_id = event.data.user_id;
		var screen_name = event.data.screen_name;
		var s=s_gi('cmpglobalvista');
		s.evar33=tweet_id;
		s.evar34='Twitter '+screen_name+' | '+user_id;
		s.events='event10';
		s.tl(this,'o','Twitter Tweet Submitted by User');
	});
	twttr.events.bind('follow', function(event) {
		var followed_user_id = event.data.user_id;
		var followed_screen_name = event.data.screen_name;
		var s=s_gi('cmpglobalvista');
		s.evar34='Twitter '+followed_screen_name+'| '+followed_user_id ;
		s.events='event11';
		s.tl(this,'o','Twitter Account Followed by User');
	});
});
    </script><!-- END TWEET BUTTON -->
</div>
						<div style="float:left;" class="gplus">
<!-- Place this tag where you want the +1 button to render -->
<g:plusone size="medium"></g:plusone>
<!-- Place this render call where appropriate -->
<script type="text/javascript">
  (function() {
    var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
    po.src = 'https://apis.google.com/js/plusone.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
  })();
</script>
</div>&nbsp;	
						<div class="addthis_toolbox addthis_default_style" addthis:url="http%3A%2F%2Fubm.io%2F2suxPzU%0A" addthis:title="A Primer on API Integration"  style="float:left;">
	<a href="http://www.addthis.com/bookmark.php?v=250&pubid=ra-4d6ec65a75410b8a" class="addthis_button_compact">share</a>
</div>&nbsp;
					</p>
					               </div>
			
           
		<h1>A Primer on API Integration</h1>
		<div class="text">
<div style="display:none">
<!-- Add the following three tags to your body for Google+ Button -->
<span itemprop="name">A Primer on API Integration</span>
<span itemprop="description">What you need to know as you consider communications APIs, and beyond</span>
</div>
			<P>
									<strong>What you need to know as you consider communications APIs, and beyond</strong>
								<P>
					No doubt you've heard about the rise of communication APIs as the leading way to enable business transformations for a digital future. As you consider whether APIs have a place in your environment, here's what you need to know about the integration process.</p><p> 

A successful platform is essentially a software base that users leverage to work with other software and content. Microsoft Windows and its various iterations is probably the largest example of a successful platform. However, what happens when two different systems have to interact? A great example of this is how Apple made it possible for the iPhone to connect with a Windows-based PC. Apple was clever to create an early-on instance of iTunes for Windows, which became its platform within other platforms. This became the successful terminal through which Apple allows iPhone users to manage their iPhones, music, and other digital content. </p><p> 

<b>Getting Set Up</b><br>

Not all platforms can speak to one another immediately. To enable programs to "talk" to one another, engineers established a process and programming method called the application program interface, or API. APIs allow technical sources the ability to "hook" two or more platforms together based on a few foundational programming methodologies. </p><p> 

To work with APIs, most programmers must have an understanding of the rules behind HTTP and the local programming languages involved in the software. Understanding the practices and methodologies of representational state transfer, or REST, also helps programmers build better connections between systems. In order to access the systems, most APIs leverage OAuth, an open standard for authorization. </p><p> 

In order to make full use of the power of API services provided by various platform systems, enterprise organizations and service providers should understand the following elements: platform as a priority; strategic objectives built on tactical execution; the goals of APIs; and how to work with HTTP, OAuth, and RESTful services. </p><p> 

<b>Platform as Priority</b><br>

As the cost of servers, memory, and disk space fell in the past decade due to digital transformation, a new market opened for the management of data services. Software as a service, or SaaS, became a new way for the IT industry to serve businesses of all sizes -- reducing the cost of operating IT services and increasing scalability. Taking advantage of the SaaS model, many companies began migrating data from on-premises solutions to cloud services.</p><p>

As a result, Amazon, Apple, Box, Dropbox, Google, and Microsoft, among many others, rushed to provide online content management. Each has taken a different route, but strategically they all have the same general goal: be the customer's primary source for content management. With that, you need to understand APIs in terms of overall strategy and tactical execution of that strategy:</p><ul>

<li><b>Strategic Objectives --</b> With the myriad of options out there to connect to and be connected with, cloud/platform content management providers must be specific in their use cases in order to optimize the value of API features. Once they identify requirements, enterprises can then review the ability of a platform to connect with their existing business systems.</p>

<li><b>Tactical Execution --</b> No strategy can be effective without defined tactics. This is where programmers and technical resources shine, bringing about value from leveraging the API. Most APIs have source code, notes, wiki pages, examples, and other pieces of information programmers and developers need to read before executing on the strategic objectives. </li></ul><p>

<b>Goal of the API</b><br>

The goal of an API is to allow systems to talk to one another and execute content-sharing based on business needs. If the business cannot define a way forward for its needs, or cannot envision a purpose for the connections between various systems, APIs may end up being a waste of time. API configuration is not difficult to maintain, but is tedious to change or modify. Therefore, making many changes to the system can be a massive problem and so makes the question of an API part of a larger business decision.</p><p>

<b>Tradeoffs</b><br>

As more users live hybrid lives, that is, using multiple platforms, APIs will continue to grow in importance and value. However, being able to maintain and understand how these systems connect -- or ought to connect -- takes serious effort with various costs involved. Working with APIs and meshing them with business management needs takes technical depth. Many businesses do not seem to understand the true value of APIs. Understanding how to best leverage them for the business needs requires serious planning and discussion. </p><p>

Once connections have been made with one system via APIs, severing connections with that platform becomes increasingly difficult -- so having a clear plan and end goal is paramount. </p><p>

APIs can be powerful connecting tools between businesses, business applications, and the platforms used to access data. Many of the big platforms on the market today provide some level of API integration. In order to leverage an API, business must identify specific requirements around their needs and tactically execute them. Otherwise, APIs become cumbersome to build and maintain. </p></p>				</P>
			</P>
		</div>   
		 
		<br clear="all" />
		<br clear="all" />
<!--		<div id="adsnative_article_ad"> </div>-->
		
				
		<!-- Mobile IMU Script Here -->
		<script type='text/javascript'>
			if (document.documentElement.clientWidth <= 767){
				document.write('<div id="div-gpt-ad-942957474691236830-4" class="responsive_imu"><center>');
				googletag.display('div-gpt-ad-942957474691236830-4');
				document.write('</center></div>');
			}
		</script>
		<!-- End: Mobile IMU Script Here -->
	<br />			<div id='div-gpt-ad-942957474691236830-38'>
			<script type='text/javascript'>
				googletag.display('div-gpt-ad-942957474691236830-38');
			</script>
		</div>
	<br />		<style type="text/css">
			@media only screen and (min-width: 63.75em) {
				.responsive_imu{
					display: none;
				}
			}
		</style>

        <div class="header left">COMMENTS</div>
        <hr/>
          
		<br clear="all" />
		<div class="comments">
			<!--[if IE]>
<script type="text/javascript">
	$(document).ready(function() {
		//IE hack to override the disqusLoggedOff.css 
		setTimeout("disqusLoggedOn()",1500);
	 });
	function disqusLoggedOn()
	{
		$('head').append('<link type="text/css" href="http://twimgs.com/brainyard/css/disqusLoggedOn.css" rel="stylesheet">');
	}
</script>
<![endif]-->
<script language='JavaScript' type='text/javascript'>
<!--
var jmessage = '';
	var jtimestamp = '';
	var jhmac = '';
	var jmessage = '';
	$.ajax({
	   type: "GET",
	   url: "/disqussetting",
	   data: "referer="+encodeURIComponent(window.location.href),
	   success: function(data){		   
		   if (data != null)
			{
			   jmessage = data.jmessage;
			   jtimestamp = data.jtimestamp;
			   jhmac = data.jhmac;					
			}
	   },
	   dataType: "json",
	   async: false,
	   cache: false
	 }	
	 );
	-->
	 
</script>
<script type="text/javascript">
  if (jmessage == null)
        $("div#disqus-hints-box").hide();
</script>
<script type="text/javascript">
var disqus_config = function () {

	var hmac1 = jhmac;
	var htimestamp = jtimestamp;
	var hmessage = jmessage;	
	if(hmac1 != null){		
			this.page.remote_auth_s3 = hmessage + ' ' + hmac1 + ' ' + htimestamp;
			this.page.api_key = "Qq6ImCn7MIzMK699FJY4iuhauNLipx3XghP08sjP0Wz9Ipk81mTrcqxz85A8OOqv";
	}
			
    this.sso = {
          name:    "UBM TechWeb",
          button:  "http://i.techweb.com/informationweek/images/ubm-techweb-logo.gif",
          icon:    "http://i.cmpnet.com/brainyard/images/favicon.ico",
          url:     "/login?assetId=200&successfulLoginRedirect=http%3A%2F%2Fwww.nojitter.com%2Fpost%2F240172721%2Fa-primer-on-api-integration",
          logout:  "/logout?redirect=http%3A%2F%2Fwww.nojitter.com%2Fpost%2F240172721%2Fa-primer-on-api-integration",
          width:   "800",
          height:  "400"
    };

    this.callbacks.onNewComment = [function() {trackComment();}];
};
</script>
<style type="text/css">
.dsq-post-tools .dsq-post-as .dsq-button{
	background: url(none);
	background-color:#c90000;
}

.dsq-post-tools .dsq-post-as .dsq-button:active{
	background: url(none);
	background-color:#e00000;
}

.dsq-post-tools .dsq-post-as .dsq-button:hover{
	background: url(none);
	background-color:#e00000;
}
.dsq-post-tools .dsq-post-as .dsq-button{
text-shadow:none;
color:white;
}
.dsq-comment-text blockquote{
	border-left:1px solid #555555;
	padding-left:15px;
	padding-top:5px;
	padding-bottom:5px;
	font-style:italic;
	font-size:15px;
	margin:15px;
	color:#999999;
	margin-bottom:10px;
	padding-right:15px;
	font-weight:bold;
}
</style>

<a name="comments"></a>
<div id="disqus_thread">
		
</div>

<script type="text/javascript">
		
    var disqus_shortname = 'no-jitter';
    var disqus_domain = 'disqus.com';
    var disqus_identifier = 'article_240172721';
	var disqus_url = 'http://www.nojitter.com/post/240172721/a-primer-on-api-integration';
		var disqus_title = '"A Primer on API Integration"';
	
	if(disqus_identifier !== null && disqus_identifier != '')
	{
		/* * * DON'T EDIT BELOW THIS LINE * * */
	    (function() {
	        var dsq = document.createElement('script'); dsq.type = 'text/javascript'; dsq.async = true;
	        dsq.src = '//' + disqus_shortname + '.disqus.com/embed.js';
	        (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
	    })();
	}
   
    
</script>
		</div>        
</div>

</div>
<!--sidebar-->
 <div id="sidebarB" class="span-9 last" >
			<div id='div-gpt-ad-942957474691236830-4'>
			<script type='text/javascript'>
				googletag.display('div-gpt-ad-942957474691236830-4');
			</script>
		</div>
	<br />			<div id='div-gpt-ad-942957474691236830-21'>
			<script type='text/javascript'>
				googletag.display('div-gpt-ad-942957474691236830-21');
			</script>
		</div>
	<!-- /end 336x90 ad -->
<!-- mod_upcoming_events -->
<img src="//twimgs.com/nojitter/v2/images/site/ec_upcoming_events2.png" />
<div id="mod_upcomingevents">
	<div class="double_wrapper_a">
		<div class="double_wrapper_b">
			<div class="tabs" >
				
				<a title="content_1" class="tab active">Webinars</a>
				<a title="content_3" class="tab">Podcasts</a>
			</div>
			<div class="tabbed_area">
			

				<div class="content_1 content" >
					<div class="mod_resources">
												<div class="item">
							<div class="title"><a href="http://webinar.enterpriseconnect.com/05312017?keycode=web" target="_blank">Meeting the Needs of the Dynamic Meeting Room</a></div>
							<div class="posting">
								<em>May 31, 2017</em>
							</div>
							<div class="text"><p>In the days of old, people in suits used to meet at a boardroom table to update each other on their work. Including a remote colleague meant setting a conference phone on the table for in-person pa</div>
						</div>
												<div class="item">
							<div class="title"><a href="http://webinar.enterpriseconnect.com/04192017?keycode=web" target="_blank">Taking Your Contact Center to the Cloud: The First Step in Your Digital Transformation Journey</a></div>
							<div class="posting">
								<em>April 19, 2017</em>
							</div>
							<div class="text"><p>Now more than ever, enterprise contact centers have a unique opportunity to lead the way towards complete, digital transformation. Moving your contact center to the cloud is a starting point, quick</div>
						</div>
												<div class="item">
							<div class="title"><a href="http://webinar.enterpriseconnect.com/04052017?keycode=web" target="_blank">5 Simple Steps to Migrate Your Communication Systems to the Cloud</a></div>
							<div class="posting">
								<em>April 5, 2017</em>
							</div>
							<div class="text"><p>Its no secret that the cloud offers significant benefits to enterprises - including cost reduction, scalability, higher efficiency, and more flexibility. If your phone system and contact center are</div>
						</div>
												<div class="controller">
							<a href="/webinars">More Webinars</a>
						</div>
						<div style="clear:both;"></div>
					</div>
				</div>
				<div class="content_3 content" >
					<div class="mod_resources">
					
									
								<div class="item">
	<div class="title"><a class="download ui-link" href="javascript:void()" data-src="http://www.nojitter.com/podcast/view/not-your-fathers-telecom-expense-management/201553" target="_blank" >Not Your Father's Telecom Expense Management</a></div>
			<div class="posting">
				<em>June 9, 2017</em>
			</div>
																<div class="text">If you think telecom expense management applies to nothing more than business phone lines, think again. Hyoun Park, founder and principal investigator with technology advisory Amalgam Insights, tells ....</div>
								</div>
								<div class="item">
	<div class="title"><a class="download ui-link" href="javascript:void()" data-src="http://www.nojitter.com/podcast/view/why-you-need-a-mobile-center-of-excellence/201549" target="_blank" >Why You Need a Mobile Center of Excellence</a></div>
			<div class="posting">
				<em>June 2, 2017</em>
			</div>
																<div class="text">Enterprises strategizing on mobility today, including for internal collaboration, don't have the luxury of learning as they go. Tony Rizzo, enterprise mobility specialist with Blue Hill Research, expl....</div>
								</div>
								<div class="item">
	<div class="title"><a class="download ui-link" href="javascript:void()" data-src="http://www.nojitter.com/podcast/view/comms-apis-pushing-the-enterprise-edge/201548" target="_blank" >Comms APIs: Pushing the Enterprise Edge</a></div>
			<div class="posting">
				<em>May 24, 2017</em>
			</div>
																<div class="text">Mark Winther, head of IDC's global telecom consulting practice, gives us his take on how CPaaS providers evolve beyond the basic building blocks and address maturing enterprise needs.</div>
								</div>
								<div class="item">
	<div class="title"><a class="download ui-link" href="javascript:void()" data-src="http://www.nojitter.com/podcast/view/ucaas-scorecard-rating-the-market-leaders/201547" target="_blank" >UCaaS Scorecard: Rating the Market Leaders</a></div>
			<div class="posting">
				<em>May 18, 2017</em>
			</div>
																<div class="text">Diane Myers, senior research director at IHS Markit, walks us through her 2017 UC-as-a-service report... and shares what might be to come in 2018.</div>
								</div>
								<div class="item">
	<div class="title"><a class="download ui-link" href="javascript:void()" data-src="http://www.nojitter.com/podcast/view/get-up-to-speed-on-the-digital-imperative/201544" target="_blank" >Get Up to Speed on the Digital Imperative</a></div>
			<div class="posting">
				<em>April 28, 2017</em>
			</div>
																<div class="text">Change isn't easy, but it is necessary. Tune in for advice and perspective from Zeus Kerravala, co-author of a "Digital Transformation for Dummies" special edition.</div>
								</div>
								<div class="item">
	<div class="title"><a class="download ui-link" href="javascript:void()" data-src="http://www.nojitter.com/podcast/view/takeaways--tips-on-ucc-spending/201543" target="_blank" >Takeaways & Tips on UC&C Spending</a></div>
			<div class="posting">
				<em>April 20, 2017</em>
			</div>
																<div class="text">Robin Gareiss, president of Nemertes Research, shares insight gleaned from the firm's 12th annual UCC Total Cost of Operations study.</div>
								</div>
								<div class="item">
	<div class="title"><a class="download ui-link" href="javascript:void()" data-src="http://www.nojitter.com/podcast/view/looking-ahead-enterprise-ucc-circa-2020/201541" target="_blank" >Looking Ahead: Enterprise UC&C Circa 2020</a></div>
			<div class="posting">
				<em>March 23, 2017</em>
			</div>
																<div class="text">Tim Banting, of Current Analysis, gives us a peek into what the next three years will bring in advance of his Enterprise Connect session exploring the question: Will there be a new model for enterpris....</div>
								</div>
								<div class="item">
	<div class="title"><a class="download ui-link" href="javascript:void()" data-src="http://www.nojitter.com/podcast/view/sbc-abcs--then-some/201538" target="_blank" >SBC ABCs... & Then Some</a></div>
			<div class="posting">
				<em>March 15, 2017</em>
			</div>
																<div class="text">Andrew Prokop, communications evangelist with Arrow Systems Integration, discusses the evolving role of the all-important session border controller.</div>
								</div>
								<div class="item">
	<div class="title"><a class="download ui-link" href="javascript:void()" data-src="http://www.nojitter.com/podcast/view/tadhackmini-orlando-what-where-when-why--how/201537" target="_blank" >TADHack-mini Orlando: What, Where, When, Why & How</a></div>
			<div class="posting">
				<em>March 9, 2017</em>
			</div>
																<div class="text">Organizer Alan Quayle gives us the lowdown on programmable communications and all you need to know about participating in this pre-Enterprise Connect hackathon.</div>
								</div>
								<div class="item">
	<div class="title"><a class="download ui-link" href="javascript:void()" data-src="http://www.nojitter.com/podcast/view/uc-lockdown-knowing-how-to-keep-hackers-at-bay/201534" target="_blank" >UC Lockdown: Knowing How to Keep Hackers at Bay</a></div>
			<div class="posting">
				<em>March 3, 2017</em>
			</div>
																<div class="text">From protecting against new vulnerabilities to keeping security assessments up to date, security consultant Mark Collier shares tips on how best to protect your UC systems.</div>
								</div>
								<div class="item">
	<div class="title"><a class="download ui-link" href="javascript:void()" data-src="http://www.nojitter.com/podcast/view/cloud-architectures-how-they-differ--what-that-means-for-you/201532" target="_blank" >Cloud Architectures: How They Differ & What That Means for You</a></div>
			<div class="posting">
				<em>February 24, 2017</em>
			</div>
																<div class="text">UC analyst Blair Pleasant sorts through the myriad cloud architectural models underlying UCaaS and CCaaS offerings, and explains why knowing the differences matter.</div>
								</div>
								<div class="item">
	<div class="title"><a class="download ui-link" href="javascript:void()" data-src="http://www.nojitter.com/podcast/view/practical-advice-for-navigating-sip-trunking/201531" target="_blank" >Practical Advice for Navigating SIP Trunking</a></div>
			<div class="posting">
				<em>February 17, 2017</em>
			</div>
																<div class="text">From the most basics of basics to the hidden gotchas, UC consultant Melissa Swartz helps demystify the complex world of SIP trunking.</div>
								</div>
								<div class="item">
	<div class="title"><a class="download ui-link" href="javascript:void()" data-src="http://www.nojitter.com/podcast/view/onprem-cloud-hybrid-how-to-approach-the-skype-for-business-decision/201530" target="_blank" >On-Prem, Cloud, Hybrid? How to Approach the Skype for Business Decision</a></div>
			<div class="posting">
				<em>February 7, 2017</em>
			</div>
																<div class="text">UC&C consultant Kevin Kieller, a partner at enableUC, shares pointers for making the right architectural choices for your Skype for Business deployment.</div>
								</div>
								<div class="item">
	<div class="title"><a class="download ui-link" href="javascript:void()" data-src="http://www.nojitter.com/podcast/view/ucaas-ins--outs-eye-on-the-enterprise-opportunity/201529" target="_blank" >UCaaS Ins & Outs: Eye on the Enterprise Opportunity</a></div>
			<div class="posting">
				<em>February 1, 2017</em>
			</div>
																<div class="text">Elka Popova, a Frost & Sullivan program director, shares a status report on the UCaaS market today and offers her perspective on what large enterprises need before committing to UC in the cloud.</div>
								</div>
								<div class="item">
	<div class="title"><a class="download ui-link" href="javascript:void()" data-src="http://www.nojitter.com/podcast/view/what-you-need-to-know-about-cloud-video-services/201528" target="_blank" >What You Need to Know About Cloud Video Services</a></div>
			<div class="posting">
				<em>January 26, 2017</em>
			</div>
																<div class="text">Andrew Davis, co-founder of Wainhouse Research and chair of the Video track at Enterprise Connect 2017, sorts through the myriad cloud video service options and shares how to tell if your choice is en....</div>
								</div>
								<div class="item">
	<div class="title"><a class="download ui-link" href="javascript:void()" data-src="http://www.nojitter.com/podcast/view/cloud-contact-center-the-new-normal/201526" target="_blank" >Cloud Contact Center: The New Normal?</a></div>
			<div class="posting">
				<em>January 23, 2017</em>
			</div>
																<div class="text">Sheila McGee-Smith, Contact Center/Customer Experience track chair for Enterprise Connect 2017, tells us what we need to know about the role cloud software is playing in contact centers today.</div>
								</div>
														
					
						<div class="controller"><a href="/podcasts/archives" target="_blank">More Podcasts</a></div>
						<div style="clear:both;"></div>
					</div>
				</div>			</div>
		</div>
	</div>
</div>
<script  type="text/javascript" >
	$('#mod_upcomingevents').noJitterTabs();
</script>
<!-- /end  mod_upcoming_events -->			<div id='div-gpt-ad-942957474691236830-36'>
			<script type='text/javascript'>
				googletag.display('div-gpt-ad-942957474691236830-36');
			</script>
		</div>
	<br />	
	</div>
	<!--footer--> 
	<div id="footer" class="span-24 last">
	<hr class="non-mobile-unit" />
	<div class="leaderboardFooter_ad">
	<span class="non-mobile-unit">
				<div id='div-gpt-ad-942957474691236830-8'>
			<script type='text/javascript'>
				googletag.display('div-gpt-ad-942957474691236830-8');
			</script>
		</div>
	</span>
	
<script type="text/javascript" language="JavaScript" src="//i.techweb.com/informationweek/elqNow/elqCfg.js"></script>
<SCRIPT TYPE='text/javascript' LANGUAGE='JavaScript' SRC='//twimgs.com/informationweek/elqNow/elqImg.js'></SCRIPT>
</div>
<div id="superfooter">
<!-- BEGIN GREY FOOTER --><div align="center">
<div id="footergrey">
<div id="top">
<!--GREY FOOTER LEFT SIDE --><div id="left">
    <a target="_blank" href="http://www.ubmtechweb.com/"><img width="88" border="0" height="111" alt="UBM Tech" src="http://img.deusm.com/images/UBM_Logo_PMS669.png"></a>
    </div>
<!-- / GREY FOOTER LEFT SIDE --><!-- GREY FOOTER rightlinks SIDE --><div id="rightlinks">
<div id="tech-brands" class="list-div">
<ul class="first-list">
<li  style="padding-bottom:9px;padding-top:2px;"><b>TECHNOLOGY GROUP<b></li>
<li><a target="_blank" href="http://www.blackhat.com/us-14/">Black Hat</a></li>
<li><a target="_blank" href="http://contentmarketinginstitute.com/">Content Marketing Institute</a></li>
<li><a target="_blank" href="http://www.contentmarketingworld.com/">Content Marketing World</a></li>
<li><a target="_blank" href="http://www.darkreading.com/">Dark Reading</a></li>
</ul>
<ul>
<li><a target="_blank" href="http://www.enterpriseconnect.com/">Enterprise Connect</a></li>
<li><a target="_blank" href="http://www.servicemanagementfusion.com/">Fusion</a></li>
<li><a target="_blank" href="http://www.gdconf.com/">GDC</a></li>
<li><a target="_blank" href="http://www.gamasutra.com/">Gamasutra</a></li>
</ul>
<ul>

<li><a target="_blank" href="http://www.thinkhdi.com/">HDI</a></li>
<li><a href="http://www.icmi.com/" target="_blank">ICMI</a></li>
<li><a target="_blank" href="http://www.informationweek.com/">InformationWeek</a></li>
<li><a target="_blank" href="http://www.interop.com">Interop ITX</a></li>
</ul>
<ul class="last-list">

<li><a target="_blank" href="//www.networkcomputing.com/">Network Computing</a></li>
<li><a target="_blank" href="//www.nojitter.com/">No Jitter</a></li>
<li><a href="http://www.vrdconf.com/" target="_blank">VRDC</a></li>
</ul></div>
<div id="communities-served" class="list-div">
<ul class="first-list"><li class="footer_title">COMMUNITIES SERVED</li>
<li><a target="_blank" href="http://tech.ubm.com/community-brands/content-marketing-2/">Content Marketing</a></li>
<li><a target="_blank" href="http://tech.ubm.com/community-brands/enterprise-it/">Enterprise IT</a></li>
<li><a target="_blank" href="http://tech.ubm.com/community-brands/enterprise-communications/">Enterprise Communications</a></li>
<li><a target="_blank" href="http://tech.ubm.com/community-brands/game-and-app-developers/">Game Developers</a></li>
<li><a target="_blank" href="http://tech.ubm.com/community-brands/information-security/">Information Security</a></li>
<li><a target="_blank" href="http://tech.ubm.com/community-brands/technical-service-and-support/">IT Services &amp; Support</a></li>
</ul></div>
<div id="working-with-us" class="list-div">
<ul class="first-list"><li class="footer_title">WORKING WITH US</li>
<li><a target="_blank" href="http://createyournextcustomer.techweb.com/contact-us/">Advertising Contacts</a></li>
<li><a target="_blank" href="http://events.ubm.com/?company=10">Event Calendar</a></li>
<li><a target="_blank" href="http://createyournextcustomer.techweb.com/">Tech Marketing</a></li>
<li><a target="_blank" href="http://createyournextcustomer.techweb.com/">Solutions</a></li>
<li><a target="_blank" href="http://tech.ubm.com/contact-us/">Contact Us</a></li>
<li><a target="_blank" href="https://wrightsmedia.com/sites/ubm/index.cfm">Licensing</a></li>
</ul></div>
</div>
<!-- / GREY FOOTER rightlinks --></div>
<!--end top--><div style="clear:both;"></div>
<!-- // to clear the right and left evenly // --><div id="bottom">
<ul><li><a class="blue" target="_blank" href="http://legal.us.ubm.com/terms-of-service/">Terms of Service</a></li>
<li><a class="blue" target="_blank" href="http://legal.us.ubm.com/privacy-policy/">Privacy Statement</a></li>
<li><a class="blue" target="_blank" href="http://reg.ubmamevents.com/UBMLegalEntities">Legal Entities</a></li>
<li>Copyright &copy; 
<script type="text/javascript">
		  <!--
		  var currentTime = new Date()
		  var year = currentTime.getFullYear()
		  document.write( year)
		  //-->
		 </script>
UBM, All rights reserved</li>
</ul></div>
</div>
<!-- / END footergrey --></div>
<!-- / END align="center" --><!-- / END GREY FOOTER --></div>
 	

</div>
         	
</div>

<script type="text/javascript">
		
    var disqus_shortname = 'no-jitter';
	
    /* * * DON'T EDIT BELOW THIS LINE * * */
    (function () {
        var s = document.createElement('script'); s.async = true;
        s.type = 'text/javascript';
        s.src = '//' + disqus_shortname + '.disqus.com/count.js';
        (document.getElementsByTagName('HEAD')[0] || document.getElementsByTagName('BODY')[0]).appendChild(s);
    }());

</script><script type="text/javascript" src="https://s7.addthis.com/js/250/addthis_widget.js#pubid=ra-4d6ec65a75410b8a"></script>
<script type="text/javascript">

  var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-2146973-15']);
  _gaq.push(['_trackPageview']);

  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();

</script>
<script type="text/javascript" src="https://ins.techweb.com/beacon/js/beacon-min.js"></script>
<script type="text/javascript">
var beacon = new UBM.Beacon({environment: 'p', apiKey: 'ee4cc70645f40ec1a556b77e64cc3a96c3832cb2b782c44e54171631bdac1bdd'});
beacon.pageview();
</script>
<!-- SiteCatalyst code version: H.16.
Copyright 1997-2008 Omniture, Inc. More info available at
http://www.omniture.com -->
<script type="text/javascript" src="//i.ubm-us.net/shared/omniture/h_s_code_remote.js" ></script>
 
<script type="text/javascript">
//check if jQuery exists before loading it. 
if(!window.jQuery)
{
   var script = document.createElement('script');
   script.type = "text/javascript";
   script.src = "//ajax.googleapis.com/ajax/libs/jquery/1.4.2/jquery.min.js";
   document.getElementsByTagName('head')[0].appendChild(script);
}
</script>
<script language='JavaScript' type='text/javascript'>
	var omnitureURL = '/omniture';
	var referer = '';
	var eVar23 = '';
	var userAgent = '';
	$.ajax({
	   type: "GET",
	   url: omnitureURL,
	   data: "referer="+encodeURIComponent(document.referrer),
	   success: function(data){		   
		   if (data != null)
			{
				referer = data.referer;
				eVar23 = data.eVar23;	
				userAgent = data.userAgent;
								
			}
	   },
	   dataType: "json",
	   async: false,
	   cache: false
	 }	
	 );
	
	 
</script>

<script language='JavaScript' type='text/javascript'>
<!--	
s.pageURL="http://www.nojitter.com/post/240172721/a-primer-on-api-integration";
s.pageName="";
s.referrer=referer;
s.server="";
s.channel="nojitter.com/post";
s.pageType="";
s.prop1="";
s.prop2="240172721";
s.prop3="240172721 | A Primer on API Integration";
s.prop4="A Primer on API Integration";
s.prop5="post";
s.prop6="";
s.prop7="Pedro Pinto";
s.prop8=userAgent;
s.prop9="";
s.prop10="";
s.prop11="";
s.prop12="";
s.prop14="";
s.prop15="";
s.prop16="";
s.prop19="False";
s.prop20="20170615";
s.prop21="";

/* Conversion Variables */
s.campaign="";
s.state="";
s.zip="";
s.events="event5";
s.products="";
s.purchaseID="";
s.eVar1="";
s.eVar2="";
s.eVar3="";
s.eVar4="";
s.eVar5="";
s.eVar6="";
s.eVar8="";
s.eVar21="";
s.eVar22="";
s.eVar23=eVar23;
s.eVar31="";

/************* DO NOT ALTER ANYTHING BELOW THIS LINE ! **************/
var s_code=s.t();if(s_code)document.write(s_code)//-->	
</script>

<noscript><a href="http://www.omniture.com" title="Web Analytics"><img
src="http://cmpglobalvista.112.2O7.net/b/ss/cmpglobalvista/1/H.16--NS/0"
height="1" width="1" border="0" alt="" /></a></noscript><!--/DO NOT REMOVE/-->

<script language="JavaScript" type="text/javascript">

   function trackComment(){
                var s=s_gi('cmpglobalvista'); 
                s.evar24=s.prop7 +" | "+ s.prop4;  
                  s.events='event8';
                  s.tl(this,'o','Article Comment Posted');
          
   }
</script>
<!-- End SiteCatalyst code version: H.16  -->
<script type="text/javascript">
adroll_adv_id = "4PP336OTMJE2PCH5ASQYOF";
adroll_pix_id = "3CGS5DA265DG5PE6LXTP4Z";
(function () {
var oldonload = window.onload;
window.onload = function(){
   __adroll_loaded=true;
   var scr = document.createElement("script");
   var host = (("https:" == document.location.protocol) ? "https://s.adroll.com" : "http://a.adroll.com");
   scr.setAttribute('async', 'true');
   scr.type = "text/javascript";
   scr.src = host + "/j/roundtrip.js";
   ((document.getElementsByTagName('head') || [null])[0] ||
    document.getElementsByTagName('script')[0].parentNode).appendChild(scr);
   if(oldonload){oldonload()}};
}());
</script><br clear="all" /> 
<div id="footerFiller"></div>
</div>
</body>
</html>
